Error -4310: Failed to connect to VM

AdminStudio 2021 | 21.0 | Automated Application Converter

The following table documents this message:

Error -4310: Failed to connect to VM

Category

Description

Message:

Error -4310 controlling virtual machine: Failed to connect to VM

Cause:

This error could be caused by the following reasons:

Virtual machine was unexpectedly shut down early.
Operating system on the virtual machine does not launch.
The Guest Agent is not running on the virtual machine.
Permissions to the virtual machine are incorrect.
Virtual machine AutoRepack_Base snapshot was taken before the machine was powered off.

Resolution:

To resolve this error, try the following:

After you have run the Virtual Machine Preparation Tool on this virtual machine, verify that the snapshot launches, automatically logs into the virtual machine, and that the Guest Agent opens.
Ensure that the virtual machine has access to the network and is visible to/accessible from the host machine (if it is running on a different computer).
Do not shut down the virtual machine in the middle of using it.
Make sure that you power off the virtual machine before taking the AutoRepack_Base snapshot.