Error -4389: Failed connecting to server

AdminStudio 2021 | 21.0 | Automated Application Converter

The following table documents this message:

Error -4389: Failed connecting to server

Category

Description

Message:

Error -4389 controlling virtual machine: Failed connecting to server

Cause:

The Automated Application Converter was unable to connect to the virtual machine server. The server machine may be unavailable.

Resolution:

To resolve this error, try the following:

Verify that the Server Address, Server Username, and Server Password properties under Virtual Machine Server on the Machines tab are set correctly for this virtual machine.
Verify that the Hyper-V or VMware ESX/ESXi server is running.
Ensure that the virtual server has access to the network and is visible to/accessible from the host machine (if it is running on a different computer).
If you are using VMware and you received XE values 22002 (55F2) or 22003 (55F3), verify that the VMware vSphere API is installed. See VMware vSphere API Requirement on the AdminStudio Machine.