Troubleshooting Database Upgrade Failed Error During Upgrade

App Portal / App Broker 2019 R1

Problem

In some instances during the upgrade process, the upgrade may fail and display the following message:

Executing Database upgrade script for database AppPortal on FLEXCM

Error detected during database upgrade. Please look at C:\ESD_Error_Log.txt for more information.

Database Upgrade failed. Check C:\ESD_Error_Log.txt for more info and contact Flexera Software for assistance.

Done!

A review of the ESD_Error_Log.txt file will reveal more detail about the cause of the error:

Failed to backup the database AppPortal.

Cannot open backup device 'C:\ESD_Upgrade_Backup'. Operating system error 5 (Access is denied).

BACKUP DATABASE is terminating abnormally.

Cause

The App Portal Upgrade performs four functions during installation:

1. Upgrade Website
2. Upgrade Database
3. Upgrade Web Services on Primary Sites
4. Backup Self Service Database

Even though the backup is last on the list of options, it is performed first.

The upgrade failure in this case is caused by insufficient permissions of the SQL service account. In order to write a file to the root of the C:\ drive, an account must be a member of the local administrators group.

Solution

Temporarily add the SQL service account to the local administrators group on the SQL server hosting the App Portal database. This will allow the SQL service account to successfully write a backup copy of the existing App Portal database to the root of the C:\ drive. Once the upgrade has completed, you can remove the SQL service account from the local administrators group.