SSH Collection Module AIX Command Reference

The following table contains the AIX command reference for the SSH Collection Model.

AIX Command Reference for the SSH Collection Model

Command

Privileged

Command Operation

Reason for Use

sudo true

Yes

Immediately returns successfully.

Used to validate access to the sudo utility.

uname -a

 

Returns all elements in the system utsname structure.

Used for a full descriptive string for the system.

uname -s

 

Returns the operating system name.

Used for OS detection.

uname -r

 

Returns the operating system minor version

Used for OS version detection.

uname -v

 

returns the operating system major version

Used for OS version detection.

uname -p

 

Returns the hardware platform type.

Used for system architecture detection.

uname -n

 

Returns the system hostname.

Used for hostname detection.

lsdev

 

Returns a list of devices on the system.

Used to determine devices eligible for further inspection.

lsdev -Cc if

 

Returns a list of network interfaces on the system.

Used to retrieve list of network devices.

ps -o etime= -p1

 

Returns details on running processes.

Used to derive the system uptime, by determining the elapsed time since the init process started.

w -h

 

Returns details of logged in users.

Used to retrieve the number of current user sign ins.

lsattr -E -l sys0 -a realmem

 

Returns details on a system logical device.

Used to determine the size of system memory.

ps -e -o pid,cputime,rssize,args

 

Returns details on running processes.

Used to retrieve a list of running processes.

lsattr -E -l procN

 

Returns details on a system logical device.

Used to retrieve CPU details, where N is a CPU device index seen from lsdev.

ifconfig -a

 

Returns details on network interfaces.

Used to retrieve details on network interfaces.

entstat $device

 

Returns statistics on an ethernet device.

Used to retrieve statistics for ethernet devices, where $device is the name of an ethernet device.

lsattr -E -l $device -a state,netaddr,netmask,netaddr6,mtu

 

Returns details on a system logical device.

Used to retrieve statistics for ethernet devices, where $device is the name of an ethernet device.

sudo getconf DISK_SIZE /dev/$device

Fallback

Returns the value of a system configuration variable.

Used to retrieve the size of physical disks reported by lsdev. The disks may have access restrictions in some configurations that require privilege elevation.

lsfs

Fallback

Returns filesystem details.

Used to retrieve a list of filesystems.

sudo df -Pk

Fallback

Returns filesystem details.

Used to retrieve filesystem size and utilization. Normally, df doesn't require elevated privileges. However, in some cases, certain file-systems cannot be shown without, and if df returns an error, it is attempted with elevated privileges.

lslpp -lJq | grep -v '^#Path'

 

Returns a list of installed software.

Used to retrieve a list of installed software, using grep to remove header lines.

vmstat 1 2

 

Returns details on system utilization.

Used to retrieve various system utilization statistics. It produces two metric reports, with a one second wait between them.

vmstat -v

 

Returns details on virtual memory utilization.

Used to retrieve detailed information on virtual memory utilization.

pagesize

 

Returns the size of a virtual memory page.

Used to convert virtual memory page utilization to byte-sizes.

iostat -Dl 1 1

 

Returns statistics on system I/O activity.

Used to retrieve statistics on system I/O.

sudo lsof -i -nP

Fallback

Returns a list of open file descriptors.

Used to retrieve details of open network sockets. Normally, lsfs doesn't require privilege elevation, however, in some cases it seems it may. To avoid interfering with engagements where this is working and not configured for privilege elevation we first try without and then fall back to try with.