SSH Collection Module Solaris Command Reference

The following table contains the Solaris command reference for the SSH Collection Model.

Solaris Command Reference for the SSH Collection Model

Command

Privileged

Command Operation

Reason for Use

sudo true

Yes

Immediately returns successfully.

Used to validate access to the sudo utility.

uname -a

 

Returns all elements in the system utsname structure.

Used for a full descriptive string for the system.

uname -s

 

Returns the operating system name.

Used for OS detection.

uname -p

 

Returns the hardware platform type.

Used for system architecture detection.

uname -n

 

Returns the system hostname.

Used for hostname detection.

uname -rv

 

Returns OS revision.

Used to determine SunOS and kernel version.

cat /etc/release

 

Returns detailed OS version string.

Used to determine Solaris version and OS build date.

zonename

 

Returns name of current zone.

Used to distinguish between global and non-global zones.

/usr/sbin/zoneadm list -p

 

Returns list of zones on system.

Used to fetch UUID of non-global zones.

uptime

 

Returns system uptime.

Used during calculation of network traffic metrics.

/usr/sbin/prtdiag -v || true

 

Returns hardware and firmware information.

(SPARC) Used to fetch hardware type, serial number, and firmware versions.

/usr/sbin/smbios -t SMB_TYPE_BIOS

 

Returns BIOS version.

(x86) Used to fetch BIOS revision.

/usr/sbin/smbios -t SMB_TYPE_SYSTEM

 

Returns hardware information.

(x86) Used to fetch hardware type and serial number.

/usr/sbin/prtconf

 

Returns hardware and memory information.

Used to determine total available RAM.

ps -e -o pid,time,rss,args

 

Returns details on running processes.

Used to retrieve a list of running processes.

/usr/sbin/psrinfo -pv

 

Returns CPU information.

Used to determine processor type, speed, and topology.

/sbin/ifconfig -a

Yes

Returns network information.

Used to determine network interface names, IP addresses, and MACs.

/sbin/dladm show-dev -p

Yes

Return physical NIC status.

(10) Used to determine speed of physical network interfaces.

/sbin/dladm show-phys -p -o LINK,MEDIA,STATE,SPEED,DUPLEX,DEVICE

 

Return physical NIC status.

(11) Used to determine speed and media type of physical network interfaces.

iostat -En

 

Return physical disk info.

Used to determine type and model of disks.

/sbin/mount -v

 

Return list of mounted filesystems.

Used to determine type and options of mounted filesystems.

df -k

Yes

Return file system capacity.

Used to determine filesystem utilization.

/usr/sbin/zpool list -H -o name,size,allocated,free,capacity,health

 

Return ZFS capacity.

Used to determine total capacity and utilization of ZFS pools.

pkginfo -li

 

Return installed software.

(10) Used to obtain versions and descriptions of installed OS packages.

pkg info

 

Return installed software.

(11) Used to obtain versions and descriptions of installed OS packages.

pkg contents -H -t file -a 'mode=?5*' -a 'mode=?7*' -o pkg.name,action.key

 

Return installed executables.

(11) Used to obtain list of executable files in installed OS packages.

vmstat 1 2

 

Return CPU, memory, and disk statistics.

Used to determine current CPU and memory utilization.

/usr/sbin/swap -l

 

Return swap memory information.

Used to determine current swap size and utilization.

kstat -p zfs:0:arcstats:size

 

Return kernel statistics.

Used to determine proportion of memory used for ZFS disk cache.

iostat -xn 1 2

 

Return disk activity.

Used to determine current disk throughput.

pfiles /proc/*

Yes

Return open files and sockets.

(< 11.2) Used to correlate running processes with network connections.

netstat -an -P tcp -f inet

 

Return network connections.

(< 11.2) Used to determine active TCP connections.

netstat -anu -P tcp -f inet

 

Return network connections and processes.

(>= 11.2) Used to determine active TCP connections and associated processes.

/sbin/dladm show-dev -s

Yes

Return network interface counters.

(10) Used to determine total network throughput.

/usr/sbin/dlstat -p -o LINK,IPKTS,RBYTES,OPKTS,OBYTES

 

Return network interface counters.

(11.0-11.2) Used to determine total network throughput.

/usr/sbin/dlstat -p -o LINK,IPKTS,IDROPS,RBYTES,OPKTS,ODROPS,OBYTES

 

Return network interface counters.

(>= 11.3) Used to determine total network throughput.