RHEL 8

PHP 7.2 and mariaDB 10.3

yum -y install curl httpd perl-Compress-Zlib php php-gd php-ldap php-mysqlnd php-pecl-zip php-xml rpm-build policycoreutils haproxy perl php-json mariadb-server mariadb 

 

systemctl enable mariadb httpd haproxy

systemctl restart mariadb httpd haproxy

rpm -i csi-X.X.X.XX-0.XXX.X86_64.php7.rpm --nodeps

After Software Vulnerability Manager is installed, run the command:

cd /usr/local/Secunia/csi/install

Disable the sample SSL file and restart httpd to reflect your changes using the commands:

echo "" > /etc/httpd/conf.d/ssl.conf

systemctl restart httpd.service

You can then execute the installer using the command:

./installationProcess.sh

When the installationProcess.sh is run, it will stop the httpd service, go through the installation/upgrade process, and Software Vulnerability Manager will be unavailable to Agents. Once the installation/upgrade process is complete, it will start the httpd service again.

If you answered yes to using SSL (HTTPS) during the installation, it is necessary to configure the firewall to accept incoming traffic on port 443 by issuing the following commands:

firewall-cmd --zone=public --add-service=https --permanent

firewall-cmd --reload

For further information regarding the setup of SSL, refer to SSL and LDAP Support.

If you answered no to using SSL (HTTPS) during the installation, it is necessary to configure the firewall to accept incoming traffic on port 80 by issuing the following commands:

firewall-cmd --zone=public --add-service=http --permanent

firewall-cmd –-reload