Prerequisites

IT Asset Management (Cloud)
To import from the ServiceNow inventory connector, you need all of the following:
  • Access to the current SaaS implementation of IT Asset Management.
  • An installation of FlexNet Beacon 16.0.0 or later (supplied with IT Asset Management 2020 R2), with good network access to your chosen ServiceNow MID server on the one hand, and to the central application server for IT Asset Management on the other.
    Tip: It is possible to install your ServiceNow MID server on your inventory beacon, provided that there are common communications requirements — for example, that you don't have a case where one requires a proxy server setting for reaching remote servers that the other cannot use. (No proxy is required or possible between the inventory beacon and the MID server, since data exchange at this level uses a simple file share.)
    The inventory beacon you choose:
    • Must have PowerShell 5.1 or later running on Windows Server 2012 or later, or on Windows 7 SP1 or later.
    • Must have the Microsoft Windows environment variable PSModulePath set to include the following path:
      %ProgramFiles%\WindowsPowerShell\Modules
  • An implementation of ServiceNow release 5.3.316 or later – that is, one of the ServiceNow releases:
    • Madrid
    • New York
    • Orlando
    • Paris.
  • At least one of the following ServiceNow plugins (enabling the collection of the raw inventory information):
    • Discovery plugin – data is imported only when discovered by ServiceNow, so this one is mandatory; and it is also a prerequisite for the following:
    • SAM plugin – this plugin provides additional information in the file flexera_software_install_export_set.csv, and without this additional plugin, that .csv file remains empty.
  • Flexera Integration application version 5.0.316 (or later) installed on ServiceNow (obtaining and installing this application are described in Setting up the Integration Application).

IT Asset Management (Cloud)

Current